Benutzer:SoylentGreen/Object-Mode

Diese Seite bezieht sich auf Blender v2.46

Die Geometrie einer Blenderszene wird aus einem oder mehreren Objekten erstellt: Hierzu gehören Lampen (Lamps), Kurven (Curves), Flächen (Surfaces), Kameras (Cameras) und die Netze (Meshes). Die Grundkörper, die im Abschnitt Grundkörper im Kapitel "Grundlegendes Mesh Modelling" beschrieben werden, bestehen aus Netzen.

Jedes Objekt kann im ObjectMode [Objekt-Modus] bewegt, gedreht und skaliert werden. Um die Geometrie eines Objektes zu ändern, bearbeiten Sie es im EditMode (siehe Punkt EditMode im Kapitel Grundlegendes Mesh Modelling).

Abbildung 1: Ein Würfel im Edit Mode. Alle Vertices sind ausgewählt und werden gelb dargestellt.
Abbildung 2: Ein Würfel im Object Mode. Der Würfel ist ausgewählt und das aktive Objekt. Er wird daher pink umrandet dargestellt.


Ein neues Objekt wird mit seinem Objektzentrum an der Stelle eingefügt, an der sich der 3D-Cursor befindet. Um einer Szene Objekte hinzuzufügen, gibt es zwei Möglichkeiten:

  • Über das Add-Menü in der Werkzeugleiste des Info-Fenster (oberer Bildschirmrand)
  • Mit Space->Add

Wollen Sie eigenständige Objekte hinzufügen, achten Sie darauf, dass Sie sich im Objekt-Modus (Abb. 2) befinden. Fügen Sie im Edit Mode (Abb. 1) ein weiteres Objekt hinzu, z.B. ein weiteres Mesh, so gehören beide Meshes zum selben Objekt.


  • Durch das Drücken der Tab-Taste können Sie in den Edit Mode wechseln (und wieder zurück). Sie können auch den Mode Auswahlbutton in der Menüzeile des 3D-Fensters benutzen, um zwischen Edit Mode und Object Mode zu wechseln. Welche Modi verfügbar sind, hängt vom Typ des Objektes ab.

Das aktive Objekt wird mit einer pinken Umrandung gezeichnet, bzw. in der Gitternetzansicht (Wireframe) wird das Gitter in pink dargestellt (Abbildung 2).

Blender3D FreeNote.gif

Kontextsensitive Menüs, Buttons und Tasten

Viele Menüs, Buttons und Tastaturkürzel sind kontextsensitiv. Ob sie angezeigt werden und welche Wirkung sie haben, hängt vom jeweiligen Modus ab. Sie sollten sich daher stets bewußt sein, in welchem Modus Sie gerade arbeiten.



Ausrichtung von ObjektenBearbeiten

Objekte werden im Objekt-Modus so eingefügt, dass ihre lokalen Achsen mit den globalen Achsen übereinstimmen, das lokale Z ist also parallel zum globalen Z usw. Fügen Sie ein neues Objekt hingegen im Edit-Modus ein, wird das Objekt zur Ansicht ausgerichtet.

  • Sie richten ein Objekt neu aus, indem Sie es drehen.
  • Um ein Objekt zu einem Koordinatenraum auszurichten, verwenden Sei Object->Transform->Align to Transform Orientation und wählen aus dem erscheinenden Popup-Menü den gewünschten Koordinatenraum aus.
  • Um ein Objekt genauso auszurichten wie ein anderes Objekt, kopieren Sie die Drehung vom aktiven auf das ausgewählte Objekt.
    • Wählen Sie die Objekte aus, die Sie ausrichten wollen.
    • Wählen Sie mit gehaltener Shift-Taste das Objekt aus, an dem ausgerichtet werden soll.
    • Mit Strg-C kopieren Sie die Drehung vom aktiven auf die ausgewählten Objekte.

Was ein Objekt als globalen Koordinatenraum ansieht, hängt davon ab, ob es einen Parent hat oder nicht.

  • Für ein Objekt ohne Parent der Koordinatenraum, der im 3D-Fenster angezeigt wird. Der Nullpunkt liegt im Schnittpunkt der X/Y/Z-Achsen.
  • Ein Objekt mit Parent übernimmt die lokalen Koordinaten des Parent als globale Koodinaten.

Rufen Sie mit N die Transform Properties auf, werden die Ortskoordinaten des Objektes im Bezug auf die globalen Koordinaten angezeigt, sowie die Rotation und die Skalierung des Objektes. Ein Objekt mit Parent wird also seine Koordinaten nicht ändern wenn der Parent bewegt wird, obwohl es dem Parent folgt.

Operationen im Object Mode durchführen!

Führen Sie Operation wie das Verschieben, Rotieren oder Skalieren eines Objektes in der Regel im Object Mode aus. Sie können zwar im Edit Mode alle Vertices auswählen, und damit scheinbar das gleiche Ergebnis erreichen. Das hat aber zwei Nachteile:

  • Die Operationen lassen sich nur schwer rückgängig machen.
  • Das Zentrum des Objektes verschiebt sich gegenüber dem Mesh, insbesondere beim Verschieben. Das hat unerwünschte Effekte, wenn Sie anschließend z.B. um das Zentrum rotieren wollen.


Objekte löschenBearbeiten

  • Mit X oder der Entf-Taste löschen Sie Objekte.

Vorsicht, mit Strg-X löschen Sie die ganze Szene und diese Aktion lässt sich nicht so einfach rückgängig machen.

Objekte verbinden (und trennen)Bearbeiten

  • Um eigenständige Objekte zu einem zusammenzufügen, wählen Sie die Objekte aus und benutzen Object->Join Objects.

Das funktioniert allerdings nur, wenn die Objekte vom gleichen Typ sind. Das neue Objektzentrum ist das Zentrum des zuvor aktiven Objektes.

Nur zur Ergänzung und im Vorgriff:

  • Mit Mesh->Vertices->Separate können Sie im Edit-Modus ausgewählte Vertices eines Objektes zu einem eigenständigen Objekt abtrennen.
... Der folgende Teil muss in den Abschnitt über Rotation von Objekten ...

Rotieren Sie ein Objekt im Object Mode, rotieren Sie die lokalen Achsen des Objektes.

 
Abbildung 4: Clear/Apply Menü

Es gibt zwei Methoden globale und lokale Achsen wieder zur Deckung zu bringen.

  1. Sie wählen Apply Size/Rotation (Strg-A) aus dem Object Menü in der Kopfzeile des 3D-Fensters. Dann bleibt die Rotation des Objektes erhalten und die lokalen Achsen werden auf die globalen gesetzt.
  2. Sie wählen Clear Rotation (Alt-R). Dann wird das Objekt "zurückgedreht", bis die lokalen und globalen Achsen übereinstimmen (Abbildung 4).


LinksBearbeiten

Die englischsprachige Vorlage dieses Textes