Blender 3D/ Tutorials/ Texturen/ UV-Einstiegstutorial

Diese Seite bezieht sich auf Blender v2.77

In diesem Beispiel texturieren wir eine DVD-Hülle. Die dafür benötigten Bilder finden Sie unten auf der Seite im Abschnitt "Originalbilder". Es gibt zwei verschiedene Varianten:

  1. Wir texturieren jede Seite einzeln und haben dann 6 verschiedene Texturen. Das ist für die UV-Abwicklung einfach, macht aber anschließend die Anwendung der Textur etwas komplizierter.
  2. Wir texturieren alle Seiten auf einmal und haben dann nur eine große Textur. Das ist für die UV-Abwicklung etwas schwieriger, macht aber die Anwendung der Texur flexibeler.
Abb. 1: Das Endergebnis


Jede Fläche bekommt eine eigene TexturBearbeiten

BildseitenBearbeiten

  • Laden Sie die drei Bilder Schmalseite/Vorderseite/Rückseite herunter und speichern Sie sie in einem Verzeichnis Ihrer Wahl.
  • Öffnen Sie eine neue Standardszene mit File->New und splitten den Bildschirm. Das rechte Fenster ändern Sie in die UV/Image Editor Ansicht.
 
Abb. 2: Die DVD Hülle mit selektierter Vorderseite
  • Öffnen Sie mit N im 3D-Fenster die Properties , wählen den Würfel im ObjectMode aus und geben unter ScaleX = 19, ScaleY = 13.5 und ScaleZ = 1.5 ein. Jetzt hat der Würfel die richtigen Proportionen und kann mit S so weit verkleinert werden, das er in der normalen Ansicht gut sichtbar ist (z.B. auf 0.05).
  • Wechseln Sie in den EditMode mit Tab und dann in den FaceSelect-Mode Strg - Tab und wählen das obere Face des Meshes aus (Abb. 2).


 
Abb. 3: Das UV Calculation Menü mit allen Abwicklungsarten
  • Drücken Sie nun U und wählen den obersten Eintrag in der Liste: Unwrap (Abb. 3).

Im UV/Image Editor erscheint ein kleines gelbes Quadrat.

  • Öffnen Sie im UV/Image Editor-Fenster das Menü «Image» und wählen den Eintrag «Open Image». Es öffnet sich der Image Browser. Hier wählen Sie das Bild, das die Vorderseite der Videohülle darstellt und bestätigen mit einem Klick auf den Button «Open Image».


 
Abbildung 4: Einstellen des Draw Type.

Das Bild wird nun im UV/Image Editor angezeigt, allerdings noch nicht auf dem Mesh im 3d View.

  • Wechseln Sie im 3D-Fenster beim Viewport Shading in den Texture-Draw Type (Abb. 4).


 
Abb. 5: Das Bild um 90 Grad rotieren

In meinem Beispiel ist das Bild allerdings noch nicht richtig auf der Hülle platziert, sondern um 90 Grad im Uhrzeigersinn verdreht. Sie können diesen Fehler entweder im 3DView oder im UV/Image Editor korrigieren. Am einfachsten ist es in diesem Fall im 3DView.

  • Drücken Sie im 3d View Strg - F und wählen im Menü den Eintrag Rotate UV.

Das Bild rotiert in der 3d Ansicht um 90 Grad. Möchten Sie in die Gegenrichtung rotieren, halten Sie beim Klicken auf UV Rotate die Umsch Taste gedrückt. Wiederholen Sie diese Aktion so oft, bis das Bild seine richtige Position erreicht hat. Bei dieser Aktion werden nicht die Vertices verschoben, sondern nur die UV-Textkoordinaten in Bezug auf das Bild.


Alternativ können Sie auch die Vertices im UV/Image-Editor-Fenster bearbeiten und verschieben.

  • Bearbeiten Sie nun die Rückseite und den Buchrücken der Schachtel nach den gleichen Prinzipien und weisen Sie die entsprechenden Graphiken zu. Also: Fläche auswählen, Unwrap, Bild laden.

Ein neues Bild erzeugenBearbeiten

 
Abb. 6: Für diese drei Seiten brauchen wir noch ein Bild.

Sind diese Arbeiten abgeschlossen, bleiben noch drei Schmalseiten übrig, die wir im nächsten Schritt texturieren müssen (siehe Abb. 6).

  • Selektieren Sie eine Seite, wickeln diese ab und wählen nun Image → New Image Alt - N.

In dem erscheinenden Menü lassen Sie alle Einstellungen unverändert bis auf die Bildgröße. Ich habe das Bild Sides genannt.

  • Setzen Sie die Bildgröße auf 256 x 256 (px) und bestätigen mit Ok (Abb. 7).

Das Bild ist jetzt zwar angelegt, muss aber in einem zweiten Schritt gesondert abgespeichert werden.

  • Wählen Sie deswegen Image → Save as Image und speichern das Bild mit einem aussagekräftigen Namen ab (in meinem Fall Sides.png).
 
Abb. 7: Einstellungen für die neue Textur.
  • Selektieren Sie nun nacheinander die restlichen, unbearbeiteten Faces, wickeln sie diese ab und weisen ihnen das gerade abgespeicherte Bild zu.

Wie groß eine Bildtextur sein muss, um auf dem Mesh sauber dargestellt zu werden hängt davon ab, wie groß diese Textur im abschließenden Renderbild sein soll. Als Sicherheitsfaktor nimmt man für das Original eine 1.5 bis 2fache Größe. Wenn das aufgebrachte Bild also im Render 200px groß ist, genügt eine Originalgröße zwischen 300 und 400px. Da es sich in diesem Fall um ein gleichmäßig schwarzes Bild handelt, treten aber selbst bei kleinen Größen keine Probleme auf.


Die Arbeiten im UV-Editor sind nun abgeschlossen, allerdings werden beim Rendern die aufgebrachten Bilder noch nicht dargestellt. Dafür muss im nächsten Schritt ein Material angelegt werden.

Material mit der Einstellung TexfaceBearbeiten

  • Wechseln Sie in die Material Buttons .
  • Falls das Objekt kein Material trägt legen Sie ein neues Material an.
  • Aktivieren Sie im Panel Options die Checkbox Face Textures.

Nun wird die Textur gerendert, allerdings ist diese Lösung beschränkt, da sich auf diese Weise nur Colormaps abbilden lassen. Diese Möglichkeit sollten Sie nur dann benutzen, wenn Sie mehr UV-Texturen als Materialindizes benutzen wollen, oder wie in unserem Fall jedem Face ein unterschiedliches Bild zuweisen möchten. Häufig wird man UV-Koordinaten auch für Normal-Maps oder Spec-Maps usw. verwenden wollen, daher ist eine andere Lösung günstiger.



Alle Flächen werden gemeinsam abgewickeltBearbeiten

 
Abb. 8 Alle Einzelbilder zu einem zusammen gefasst. Die einzelnen Flächen wurden neu abgewickelt und auf dem Bild platziert.
  • Laden Sie das Bild herunter, auf dem alle Seiten dargestellt sind.
  • Bereiten Sie das Objekt und die Arbeitsumgebung so vor, wie es oben dargestellt wurde.
  • Wählen Sie im Edit-Modus alle Flächen aus und wickeln Sie diese ab.
  • Laden Sie das Bild.

Die Flächen liegen alle übereinander, jetzt wird Fläche nach Fläche ausgewählt, und an die Textur angepasst.

  • Wählen Sie die erste Fläche aus.
  • Verschieben/Skalieren/Rotieren Sie im UV/Image-Editor die UV-Koordinaten so lange, bis der gewünschte Bildausschnitt auf dem Objekt zu sehen ist.
  • Wiederholen Sie diesen Vorgang für alle Flächen.

Das Ergebnis sieht dann so aus wie in Abb. 8.


Material mit der Einstellung UVBearbeiten

Der Vorteil dieser Methode liegt darin, dass UV-Texturen nun auch für Aspekte wie z.B. Spec, Bump und Nor verwendet werden können. Deswegen ist dies der Normalfall.

  • Falls noch nicht vorhanden, legen Sie eine neue Textur an und rufen das soeben erstellte Bild in den Texture Buttons als «Image» auf.
  • Unter Mapping wählen Sie Coordinates->UV.

Map können Sie freilassen, solange Sie nur eine UV-Map haben, wird diese automatisch verwendet.

  • Wenn Sie nun F 12 drücken, wird das Modell mit der Textur gerendert.



OriginalbilderBearbeiten